Does the code need to be updated since Microsoft updated the toolkit to 4.4?

Oct 17, 2012 at 2:06 AM

I updated the Microsoft SSO toolkit to version 4.4.  My Luminis SSO is not working.  Does the Luminis SSO code need an update?

Oct 17, 2012 at 2:09 AM

I am getting errors on the LDAP.cs file.

Oct 17, 2012 at 2:47 PM

our SSO stopped working out of the blue without upgrading the MS SSO toolkit.  Nothing was changed on the luminis side.  Error is below.  Microsoft support fixed it but I was not involved in the call and am still waiting to find out how it was fixed.

Source Error:

 
Line 14: using System.Web.UI.WebControls.WebParts;
Line 15: using System.Web.UI.HtmlControls;
Line 16: using Windows.Live.SSO;
Line 17: 
Line 18: #endregion


Source File: c:\Inetpub\wwwroot\SSOPortal\Public\Redirect.aspx.cs    Line: 16 


Show Detailed Compiler Output:

c:\windows\system32\inetsrv> "c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\csc.exe" /t:library /utf8output /R:"c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\mscorlib.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.ServiceModel.Web\3.5.0.0__31bf3856ad364e35\System.ServiceModel.Web.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.WorkflowServices\3.5.0.0__31bf3856ad364e35\System.WorkflowServices.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.ServiceModel\3.0.0.0__b77a5c561934e089\System.ServiceModel.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Drawing\2.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.IdentityModel\3.0.0.0__b77a5c561934e089\System.IdentityModel.dll" /R:"C:\WINDOWS\assembly\GAC_32\System.Data\2.0.0.0__b77a5c561934e089\System.Data.dll" /R:"C:\WINDOWS\assembly\GAC_32\System.EnterpriseServices\2.0.0.0__b03f5f7f11d50a3a\System.EnterpriseServices.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System\2.0.0.0__b77a5c561934e089\System.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Configuration\2.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Xml\2.0.0.0__b77a5c561934e089\System.Xml.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Runtime.Serialization\3.0.0.0__b77a5c561934e089\System.Runtime.Serialization.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.DirectoryServices\2.0.0.0__b03f5f7f11d50a3a\System.DirectoryServices.dll" /R:"C:\WINDOWS\assembly\GAC_32\System.Web\2.0.0.0__b03f5f7f11d50a3a\System.Web.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Web.Services\2.0.0.0__b03f5f7f11d50a3a\System.Web.Services.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.DirectoryServices.Protocols\2.0.0.0__b03f5f7f11d50a3a\System.DirectoryServices.Protocols.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Web.Mobile\2.0.0.0__b03f5f7f11d50a3a\System.Web.Mobile.dll" /out:"c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ssoportal\517d1884\4a4151a0\App_Web_hqwafdss.dll" /D:DEBUG /debug+ /optimize- /win32res:"c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ssoportal\517d1884\4a4151a0\hqwafdss.res" /w:4 /nowarn:1659;1699;1701  "c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ssoportal\517d1884\4a4151a0\App_Web_hqwafdss.0.cs" "c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ssoportal\517d1884\4a4151a0\App_Web_hqwafdss.1.cs" "c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ssoportal\517d1884\4a4151a0\App_Web_hqwafdss.2.cs"


Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.3053
for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727
Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

c:\Inetpub\wwwroot\SSOPortal\Public\Redirect.aspx.cs(16,7): error CS0246: The type or namespace name 'Windows' could not be found (are you missing a using directive or an assembly reference?)
Oct 17, 2012 at 4:36 PM

Do you know who helped you at Microsoft?  No one has called me back only to say that they are working on it.

Oct 17, 2012 at 5:02 PM

I can’t remember – but I’ll try too while lunch. I’ll also look through my email – Richard something comes to mind.

From: donnatn [email removed]
Sent: Wednesday, October 17, 2012 11:37 AM
To: Emmons, Crystal
Subject: Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]

From: donnatn

Do you know who helped you at Microsoft? No one has called me back only to say that they are working on it.

Oct 17, 2012 at 6:41 PM

Richard Wakeman Richard.Wakeman@microsoft.com this is the guy that helped me way back when.

Keep me in the loop.

Crystal

From: donnatn [email removed]
Sent: Wednesday, October 17, 2012 11:37 AM
To: Emmons, Crystal
Subject: Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]

From: donnatn

Do you know who helped you at Microsoft? No one has called me back only to say that they are working on it.

Developer
Oct 18, 2012 at 7:28 PM

Oh my, I haven't looked at the SSO toolkit in eons.  I do still work with Microsoft, but mostly focused on Office 365 and our new ability to have ADFS and SSO through identity federation as opposed to the Live@edu Portal SSO Toolkit. 

Looking quickly at the error, it appears to be a compilation error.  I'm guessing that when you inserted the new URL into the file, that one of a couple of things could have happened. 

First, I'd double-check to make sure you didn't leave out a quote at the beginning or end of the string, or that you are not dealing with some invalid character.  If you paste the URL into notepad, and copy it back out, you can sometimes convert unanticipated Unicode characters that were potentially copied from somewhere else.

Second, make sure you didn't copy-and-paste the file as a backup before you made any modifications.  If you have a copy of a file in the ASP.NET folder hierarchy, it will attempt to compile it.  Thus, a copied backup file will cause a collision.  Make sure you move any of those files outside the folder hierarchy to somewhere completely different.

-Richard

Oct 18, 2012 at 8:28 PM

We had to re-write the files in the Public folder to get it to work again. Luckily, we have a web programmer on staff now that could edit the code after I explained what was done before. Do you have any idea on how many people use this code? How do most people handle giving students SSO to Live@ Edu or Office 365?

Thanks

Donna

______________________________

Donna Appleget

Systems Analyst

Chattanooga State Community College

4501 Amnicola Highway

Chattanooga, TN 37406

Voice: 423-697-2572

Fax: 423-697-4484

______________________________

From: rwakeman [email removed]
Sent: Thursday, October 18, 2012 3:29 PM
To: Donna Appleget
Subject: Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]

From: rwakeman

Oh my, I haven't looked at the SSO toolkit in eons. I do still work with Microsoft, but mostly focused on Office 365 and our new ability to have ADFS and SSO through identity federation as opposed to the Live@edu Portal SSO Toolkit.

Looking quickly at the error, it appears to be a compilation error. I'm guessing that when you inserted the new URL into the file, that one of a couple of things could have happened.

First, I'd double-check to make sure you didn't leave out a quote at the beginning or end of the string, or that you are not dealing with some invalid character. If you paste the URL into notepad, and copy it back out, you can sometimes convert unanticipated Unicode characters that were potentially copied from somewhere else.

Second, make sure you didn't copy-and-paste the file as a backup before you made any modifications. If you have a copy of a file in the ASP.NET folder hierarchy, it will attempt to compile it. Thus, a copied backup file will cause a collision. Make sure you move any of those files outside the folder hierarchy to somewhere completely different.

-Richard

Oct 18, 2012 at 8:38 PM

I will probably switch to Federation and Directory Synchronization when the students convert to Office 365. I’m looking into it now for staff testing.

From: donnatn [email removed]
Sent: Thursday, October 18, 2012 3:29 PM
To: Emmons, Crystal
Subject: Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]

From: donnatn

We had to re-write the files in the Public folder to get it to work again. Luckily, we have a web programmer on staff now that could edit the code after I explained what was done before. Do you have any idea on how many people use this code? How do most people handle giving students SSO to Live@ Edu or Office 365?

Thanks

Donna

______________________________

Donna Appleget

Systems Analyst

Chattanooga State Community College

4501 Amnicola Highway

Chattanooga, TN 37406

Voice: 423-697-2572

Fax: 423-697-4484

______________________________

From: rwakeman [email removed]
Sent: Thursday, October 18, 2012 3:29 PM
To: Donna Appleget
Subject: Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]

From: rwakeman

Oh my, I haven't looked at the SSO toolkit in eons. I do still work with Microsoft, but mostly focused on Office 365 and our new ability to have ADFS and SSO through identity federation as opposed to the Live@edu Portal SSO Toolkit.

Looking quickly at the error, it appears to be a compilation error. I'm guessing that when you inserted the new URL into the file, that one of a couple of things could have happened.

First, I'd double-check to make sure you didn't leave out a quote at the beginning or end of the string, or that you are not dealing with some invalid character. If you paste the URL into notepad, and copy it back out, you can sometimes convert unanticipated Unicode characters that were potentially copied from somewhere else.

Second, make sure you didn't copy-and-paste the file as a backup before you made any modifications. If you have a copy of a file in the ASP.NET folder hierarchy, it will attempt to compile it. Thus, a copied backup file will cause a collision. Make sure you move any of those files outside the folder hierarchy to somewhere completely different.

-Richard

Feb 7, 2013 at 1:34 PM
Hi Guys,
Were currently moving towards office 365 as part of bigger project and are now preparing to work on luminis 4 SSO to office 365. Do you have any information on how to achive SSO to office 365 or code samples please?

Thanking you in advance for nay help.
Feb 7, 2013 at 2:12 PM
<div> <p><span style="font-size:11.0pt; font-family:">I do not, but we also will be pursuing this - I’ll forward the question to my co-worker.</span></p> <p><span style="font-size:11.0pt; font-family:"></span></p> <p><span style="font-size:11.0pt; font-family:"></span></p> <p><span style="font-size:11.0pt; font-family:"></span></p> <div> <div style="border:none; border-top:solid #B5C4DF 1.0pt; padding:3.0pt 0in 0in 0in"> <p><b><span style="font-size:10.0pt; font-family:">From:</span></b><span style="font-size:10.0pt; font-family:"> cliffordmarks [email removed] <br> <b>Sent:</b> Thursday, February 07, 2013 8:34 AM<br> <b>To:</b> Emmons, Crystal<br> <b>Subject:</b> Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]</span></p> </div> </div> <p></p> <p><span style="font-size:9.0pt; font-family:">From: cliffordmarks</span></p> <div id="ThreadNotificationPostBody" style="margin-bottom:24.0pt"> <p><span style="font-size:9.0pt; font-family:">Hi Guys, <br> Were currently moving towards office 365 as part of bigger project and are now preparing to work on luminis 4 SSO to office 365. Do you have any information on how to achive SSO to office 365 or code samples please? <br> <br> Thanking you in advance for nay help.</span></p> </div> </div>
Developer
Feb 7, 2013 at 2:44 PM
What is your timeline for the transition to Office 365?
Feb 7, 2013 at 2:54 PM
<div> <p><span style="font-size:11.0pt; font-family:">Based on the emails I’ve received, we must upgrade by Fall 2013. We don’t have a plan at the moment. Our Luminis Admin is supposed to be looking into things. I do note that the St. John’s Cloud and old SSO will no longer work – any suggestions?</span></p> <p><span style="font-size:11.0pt; font-family:"></span></p> <p><span style="font-size:11.0pt; font-family:"></span></p> <div> <div style="border:none; border-top:solid #B5C4DF 1.0pt; padding:3.0pt 0in 0in 0in"> <p><b><span style="font-size:10.0pt; font-family:">From:</span></b><span style="font-size:10.0pt; font-family:"> rwakeman [email removed] <br> <b>Sent:</b> Thursday, February 07, 2013 9:45 AM<br> <b>To:</b> Emmons, Crystal<br> <b>Subject:</b> Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]</span></p> </div> </div> <p></p> <p><span style="font-size:9.0pt; font-family:">From: rwakeman</span></p> <div id="ThreadNotificationPostBody" style="margin-bottom:24.0pt"> <p><span style="font-size:9.0pt; font-family:">What is your timeline for the transition to Office 365?</span></p> </div> </div>
Feb 7, 2013 at 3:30 PM
<div> <p><span style="font-size:11.0pt; font-family:">Haven’t set one although I was thinking of starting on it this summer around the middle of May.</span></p> <p><span style="font-size:11.0pt; font-family:"></span></p> <div> <p><span style="font-size:11.0pt; font-family:">______________________________ </span> </p> <p><span style="font-size:11.0pt; font-family:">Donna Appleget</span></p> <p><span style="font-size:11.0pt; font-family:">Systems Analyst</span></p> <p><span style="font-size:11.0pt; font-family:">IT Services</span></p> <p><span style="font-size:11.0pt; font-family:">Chattanooga State Community College</span></p> <p><span style="font-size:11.0pt; font-family:">4501 Amnicola Highway</span></p> <p><span style="font-size:11.0pt; font-family:">Chattanooga, TN 37406</span></p> <p><span style="font-size:11.0pt; font-family:">Voice: 423-697-2572</span></p> <p><span style="font-size:11.0pt; font-family:">Fax: 423-697-4484</span></p> <p><span style="font-size:11.0pt; font-family:">______________________________</span></p> </div> <p><span style="font-size:11.0pt; font-family:"></span></p> <div> <div style="border:none; border-top:solid #B5C4DF 1.0pt; padding:3.0pt 0in 0in 0in"> <p><b><span style="font-size:10.0pt; font-family:">From:</span></b><span style="font-size:10.0pt; font-family:"> rwakeman [email removed] <br> <b>Sent:</b> Thursday, February 07, 2013 10:45 AM<br> <b>To:</b> Donna Appleget<br> <b>Subject:</b> Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]</span></p> </div> </div> <p></p> <p><span style="font-size:9.0pt; font-family:">From: rwakeman</span></p> <div id="ThreadNotificationPostBody" style="margin-bottom:24.0pt"> <p><span style="font-size:9.0pt; font-family:">What is your timeline for the transition to Office 365?</span></p> </div> </div>
Feb 7, 2013 at 3:39 PM
Hi
Our time line is for feburary to April to complete Office 365 installation and to provide luminis portal connector to it.
Then in June is when they plan to release it to students.
Feb 7, 2013 at 4:09 PM
<div> <p><span style="font-size:11.0pt; font-family:">I am not sure exactly what the difference will be. I can go into my student email account and create office documents, store files… What will we get that is different?</span></p> <p><span style="font-size:11.0pt; font-family:"></span></p> <p><span style="font-size:11.0pt; font-family:">To get our SSO to work with the last SSO Toolkit update we had to edit some of the web files to accommodate the Luminis information. I can post the files if anyone is interested. Can I post files to this site?</span></p> <p><span style="font-size:11.0pt; font-family:"></span></p> <div> <p><span style="font-size:11.0pt; font-family:">______________________________ </span> </p> <p><span style="font-size:11.0pt; font-family:">Donna Appleget</span></p> <p><span style="font-size:11.0pt; font-family:">Systems Analyst</span></p> <p><span style="font-size:11.0pt; font-family:">IT Services</span></p> <p><span style="font-size:11.0pt; font-family:">Chattanooga State Community College</span></p> <p><span style="font-size:11.0pt; font-family:">4501 Amnicola Highway</span></p> <p><span style="font-size:11.0pt; font-family:">Chattanooga, TN 37406</span></p> <p><span style="font-size:11.0pt; font-family:">Voice: 423-697-2572</span></p> <p><span style="font-size:11.0pt; font-family:">Fax: 423-697-4484</span></p> <p><span style="font-size:11.0pt; font-family:">______________________________</span></p> </div> <p><span style="font-size:11.0pt; font-family:"></span></p> <div> <div style="border:none; border-top:solid #B5C4DF 1.0pt; padding:3.0pt 0in 0in 0in"> <p><b><span style="font-size:10.0pt; font-family:">From:</span></b><span style="font-size:10.0pt; font-family:"> cliffordmarks [email removed] <br> <b>Sent:</b> Thursday, February 07, 2013 11:39 AM<br> <b>To:</b> Donna Appleget<br> <b>Subject:</b> Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]</span></p> </div> </div> <p></p> <p><span style="font-size:9.0pt; font-family:">From: cliffordmarks</span></p> <div id="ThreadNotificationPostBody" style="margin-bottom:24.0pt"> <p><span style="font-size:9.0pt; font-family:">Hi <br> Our time line is for feburary to April to complete Office 365 installation and to provide luminis portal connector to it. <br> Then in June is when they plan to release it to students.</span></p> </div> </div>
Mar 21, 2013 at 1:56 PM
Edited Mar 21, 2013 at 2:05 PM
We are also looking at upgrading to 365. Luminis support has stated that they do not support SSO for this right now. Has anyone heard anything about a toolkit that will work? Could you please detail the edits you had to make to accommodate Luminis info for the last toolkit? Thanks!
Mar 21, 2013 at 2:56 PM

You can’t use the toolkit anymore. You will need to get a test 365 site and set up ADFS to connect to it. There are instructions on how to do this on the http://eduadmin.live.com/ site.

This must be done by 9/13.

______________________________

Donna Appleget

Systems Analyst

IT Services

Chattanooga State Community College

4501 Amnicola Highway

Chattanooga, TN 37406

Voice: 423-697-2572

Fax: 423-697-4484

______________________________

From: rstorch [email removed]
Sent: Thursday, March 21, 2013 9:57 AM
To: Donna Appleget
Subject: Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]

From: rstorch

We are also looking at upgrading to 365. Luminis support has stated that they do not support SSO for this right now. Has anyone heard anything
about a toolkit that will work? Could you please detail the edits you had to make to accommodate Luminis info for the last toolkit? Thanks!

Mar 21, 2013 at 2:56 PM

You can set up a link to get to it like we did with the toolkit but you have to use ADFS.

______________________________

Donna Appleget

Systems Analyst

IT Services

Chattanooga State Community College

4501 Amnicola Highway

Chattanooga, TN 37406

Voice: 423-697-2572

Fax: 423-697-4484

______________________________

From: rstorch [email removed]
Sent: Thursday, March 21, 2013 9:57 AM
To: Donna Appleget
Subject: Re: Does the code need to be updated since Microsoft updated the toolkit to 4.4? [LuminisLiveSSO:399678]

From: rstorch

We are also looking at upgrading to 365. Luminis support has stated that they do not support SSO for this right now. Has anyone heard anything
about a toolkit that will work? Could you please detail the edits you had to make to accommodate Luminis info for the last toolkit? Thanks!